summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEmre Ucan <eucan@de.adit-jv.com>2018-02-23 10:11:25 +0100
committerEmre Ucan <eucan@de.adit-jv.com>2018-02-23 15:00:56 +0100
commitce7d256671c1a4a01335978856f093c0283b7539 (patch)
treec8312397787b28792fe14b19a9cae05e35578290 /CMakeLists.txt
parent768f358247fb8f80c931f449f30700c67e8db2e8 (diff)
downloadwayland-ivi-extension-ce7d256671c1a4a01335978856f093c0283b7539.tar.gz
cmake: set CFLAGS for extra warnings
Compiler warnings are generally good to track issues in source code. I disabled unused-parameter warnings, because we cannot control parameters of external library functions Signed-off-by: Emre Ucan <eucan@de.adit-jv.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 693ebfc..d408ea0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,9 @@ project(wayland-ivi-extension)
SET(IVI_EXTENSION_VERSION 2.1.0)
SET(ILM_API_VERSION 2.1.0)
+SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wno-unused-parameter" )
+SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-unused-parameter" )
+
add_subdirectory(protocol)
add_subdirectory(weston-ivi-shell)