summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimo Lotterbach <timo.lotterbach@bmw-carit.de>2014-01-31 15:59:02 +0100
committerTimo Lotterbach <timo.lotterbach@bmw-carit.de>2014-01-31 15:59:02 +0100
commitcdb466a9964496fb23cb014df82b2db3cd75c185 (patch)
treec4eb1a0f49f4b3696784a1dbbf8ce4dfc19dd923 /CMakeLists.txt
parent2f5d78a15960957ba8cdea0fa217c1b488012bfc (diff)
downloadwayland-ivi-extension-cdb466a9964496fb23cb014df82b2db3cd75c185.tar.gz
added ivi-extension-protocol library
this library takes care to generate header and source files from XML files. All generated files are now stored in the build directory. ilmCommon and weston-ivi-shell now just use the new library and don't care about code generation any more. In addition, a lot of duplicated code compilation is removed, resulting in faster builds. This patch also fixes an issue, that file generation was done every time a build was started. This resulted in full rebuilds all the time. Signed-off-by: Timo Lotterbach <timo.lotterbach@bmw-carit.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c717f25..c203264 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
############################################################################
#
-# Copyright 2010-2012 BMW Car IT GmbH
+# Copyright 2010-2014 BMW Car IT GmbH
# Copyright (C) 2011 DENSO CORPORATION and Robert Bosch Car Multimedia Gmbh
#
#
@@ -23,11 +23,11 @@ project(wayland-ivi-extension)
SET(ILM_VERSION "1.2.0")
-#===========================================================================================================
-# cmake configuration
-#===========================================================================================================
-add_subdirectory(ivi-layermanagement-api/ilmClient)
+add_subdirectory(protocol)
+
+add_subdirectory(weston-ivi-shell)
+
add_subdirectory(ivi-layermanagement-api/ilmCommon)
+add_subdirectory(ivi-layermanagement-api/ilmClient)
add_subdirectory(ivi-layermanagement-api/ilmControl)
-add_subdirectory(weston-ivi-shell)
add_subdirectory(ivi-layermanagement-examples)