summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNobuhiko Tanibata <NOBUHIKO_TANIBATA@denso.co.jp>2013-11-27 11:12:45 +0900
committerNobuhiko Tanibata <NOBUHIKO_TANIBATA@denso.co.jp>2013-11-27 11:41:49 +0900
commit682655147a8c2b5b5df3db2a03c495630bf374a5 (patch)
tree254c1a8a553f22709d9b717ca2b3619cdec19827 /CMakeLists.txt
parentc487533a94363a7f7d4032bcc1be27f1509e6aa7 (diff)
downloadwayland-ivi-extension-682655147a8c2b5b5df3db2a03c495630bf374a5.tar.gz
cmake: Root CMakeLists.txt for cmake
Signed-off-by: Nobuhiko Tanibata <NOBUHIKO_TANIBATA@denso.co.jp>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..81b3d8c
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,35 @@
+############################################################################
+#
+# Copyright 2010-2012 BMW Car IT GmbH
+# Copyright (C) 2011 DENSO CORPORATION and Robert Bosch Car Multimedia Gmbh
+#
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+############################################################################
+
+cmake_minimum_required (VERSION 2.6)
+project (LayerManager)
+
+#===========================================================================================================
+# cmake configuration
+#===========================================================================================================
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules/")
+include(${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules/DefaultSettings.txt)
+include(${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules/CMakeVersions.txt)
+include(${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules/CustomMacros.txt)
+add_subdirectory(ivi-layermanagement-api/ilmClient)
+add_subdirectory(ivi-layermanagement-api/ilmCommon)
+add_subdirectory(ivi-layermanagement-api/ilmControl)
+add_subdirectory(weston-ivi-shell)
+add_subdirectory(config)