summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 06c2ac4..0d52584 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -7,16 +7,17 @@ AM_CFLAGS = $(DEPS_CFLAGS) $(CHECK_CFLAGS)
endif
-localstate_DATA = data/attachToExistingCache.tar.gz data/rct_compare.tar.gz
+persdatadir = $(datadir)/persistence/test-data
+persdata_DATA = data/attachToExistingCache.tar.gz data/rct_compare.tar.gz
# Add config file to distribution
-EXTRA_DIST = $(localstate_DATA)
+EXTRA_DIST = $(persdata_DATA)
noinst_PROGRAMS = test_pco_key_value_store persistence_common_object_test
#persistence_sqlite_experimental
test_pco_key_value_store_SOURCES = test_pco_key_value_store.c
-test_pco_key_value_store_CFLAGS = $(AM_CFLAGS) $(ARCHIVELIB_CFLAGS) $(ZLIB_CFLAGS)
+test_pco_key_value_store_CFLAGS = $(AM_CFLAGS) $(ARCHIVELIB_CFLAGS) $(ZLIB_CFLAGS) -DPERS_TEST_DATA_DIR='"$(persdatadir)"'
test_pco_key_value_store_LDADD = $(DLT_LIBS) $(SQLITE_LIBS) $(DEPS_LIBS) $(CHECK_LIBS) $(ARCHIVELIB_LIBS) $(ZLIB_LIBS) \
$(top_srcdir)/src/libpers_common.la