summaryrefslogtreecommitdiff
path: root/generated/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'generated/Makefile.am')
-rw-r--r--generated/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/generated/Makefile.am b/generated/Makefile.am
new file mode 100644
index 0000000..52192d4
--- /dev/null
+++ b/generated/Makefile.am
@@ -0,0 +1,29 @@
+#######################################################################################################################
+#
+# Copyright (C) 2012 Continental Automotive Systems, Inc.
+#
+# Author: Ana.Chisca@continental-corporation.com
+#
+# Makefile template for the Persistence Administration Service generated sources
+#
+# Process this file with automake to produce a Makefile.in.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#######################################################################################################################
+
+# List generated sources here to assert that they are available at build start
+BUILT_SOURCES = PasClientNotificationGen.c \
+ PasClientNotificationGen.h
+
+# Delete all generated files on 'make clean'
+CLEANFILES = PasClientNotificationGen.c \
+ PasClientNotificationGen.h
+
+
+# Targets to create generated sources during the build
+
+PasClientNotificationGen.c PasClientNotificationGen.h: $(top_srcdir)/dbus_specifications/org.genivi.persistence.admin.xml
+ gdbus-codegen --interface org.genivi.persistence. --c-namespace OipPersistence --generate-c-code PasClientNotificationGen $(top_srcdir)/dbus_specifications/org.genivi.persistence.admin.xml