summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 8a3fa87..d957dd2 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,7 +1,7 @@
AUTOMAKE_OPTIONS = foreign
if DEBUG
-AM_CFLAGS = $(DEPS_CFLAGS) $(CHECK_CFLAGS) -g
+AM_CFLAGS = $(DEPS_CFLAGS) $(CHECK_CFLAGS)
#AM_CFLAGS = -fprofile-arcs -ftest-coverage $(DEPS_CFLAGS) $(CHECK_CFLAGS) -g
else
AM_CFLAGS = $(DEPS_CFLAGS) $(CHECK_CFLAGS)
@@ -9,6 +9,7 @@ AM_CFLAGS = $(DEPS_CFLAGS) $(CHECK_CFLAGS)
endif
noinst_PROGRAMS = persistence_client_library_test \
+ persistence_client_library_test_file \
persistence_client_library_dbus_test
persistence_client_library_dbus_test_SOURCES = persistence_client_library_dbus_test.c
@@ -19,8 +20,11 @@ persistence_client_library_test_SOURCES = persistence_client_library_test.c
persistence_client_library_test_LDADD = $(DEPS_LIBS) $(CHECK_LIBS) \
$(top_builddir)/src/libpersistence_client_library.la
+persistence_client_library_test_file_SOURCES = persistence_client_library_test_file.c
+persistence_client_library_test_file_LDADD = $(DEPS_LIBS) $(CHECK_LIBS) \
+ $(top_builddir)/src/libpersistence_client_library.la
-TESTS=persistence_client_library_test
+TESTS=persistence_client_library_test persistence_client_library_test_file