summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorIngo Huerner <ingo_huerner@mentor.com>2016-12-09 15:43:30 +0100
committerIngo Huerner <ingo_huerner@mentor.com>2016-12-09 15:43:30 +0100
commitc2ef1013077ecb7936c8254ee16e39fbc67435a9 (patch)
treea2b25ce2f45c19a7a9b6c753b22eb0c106b3a46a /tools/Makefile.am
parentc02dd383c15b907deaf62f4c3566821ff69da91b (diff)
downloadpersistence-client-library-c2ef1013077ecb7936c8254ee16e39fbc67435a9.tar.gz
Added persistence database viewer
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 0000000..5f915a1
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,18 @@
+AUTOMAKE_OPTIONS = foreign
+
+if DEBUG
+AM_CFLAGS =$(DEPS_CFLAGS) $(CHECK_CFLAGS) -g
+else
+AM_CFLAGS = $(DEPS_CFLAGS) $(CHECK_CFLAGS)
+#AM_CFLAGS = -fprofile-arcs -ftest-coverage $(DEPS_CFLAGS) $(CHECK_CFLAGS)
+endif
+
+bin_PROGRAMS = persistence_client_tool \
+ persistence_db_viewer
+
+persistence_client_tool_SOURCES = persistence_client_tool.c
+persistence_client_tool_LDADD = $(DEPS_LIBS)
+
+persistence_db_viewer_SOURCES = persistence_db_viewer.c
+persistence_db_viewer_LDADD = $(DEPS_LIBS)
+