summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorihuerner <ihuerner@b9707d8c-442e-47db-affb-152dabb2260b>2012-08-30 11:43:42 +0000
committerihuerner <ihuerner@b9707d8c-442e-47db-affb-152dabb2260b>2012-08-30 11:43:42 +0000
commita437ec80062eef34e861c18488838464aeac1f3b (patch)
treefba05100ed40a6d9beaa5854d08555e0da08a16d /src/Makefile.am
parentf27098df091819c7eb467607b0ceeb1739a0add4 (diff)
downloadpersistence-client-library-a437ec80062eef34e861c18488838464aeac1f3b.tar.gz
Added debug version to configure; Now custom client lib functions will be called; stabilized custom library feature; added new test data; Now custom client lib functions will be called; Added debug configure switch (debug was by default activated (rev. 1380)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0e43191..3f59e3f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,15 +1,22 @@
AUTOMAKE_OPTIONS = foreign
-AM_CFLAGS =$(DEPS_CFLAGS) -Wall -I../include \
+if DEBUG
+AM_CFLAGS =$(DEPS_CFLAGS) -g -I../include \
-I/usr/include/glib-2.0 \
-I/usr/include/dbus-1.0 \
-I/usr/include/dconf-dbus-1 \
- -I/usr/lib/glib-2.0/include
+ -I/usr/lib/glib-2.0/include
+else
+AM_CFLAGS =$(DEPS_CFLAGS) -I../include \
+ -I/usr/include/glib-2.0 \
+ -I/usr/include/dbus-1.0 \
+ -I/usr/include/dconf-dbus-1 \
+ -I/usr/lib/glib-2.0/include
+endif
include_HEADERS = ../include/persistence_client_library_key.h ../include/persistence_client_library_file.h
-
lib_LTLIBRARIES = libpersistence_client_library.la
libpersistence_client_library_la_LIBADD = $(DEPS_LIBS) -ldconf -ldl -ldconf-dbus-1 -lmygvdb