summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIngo Huerner <ingo_huerner@mentor.com>2016-12-09 15:43:30 +0100
committerIngo Huerner <ingo_huerner@mentor.com>2016-12-09 15:43:30 +0100
commitc2ef1013077ecb7936c8254ee16e39fbc67435a9 (patch)
treea2b25ce2f45c19a7a9b6c753b22eb0c106b3a46a /configure.ac
parentc02dd383c15b907deaf62f4c3566821ff69da91b (diff)
downloadpersistence-client-library-c2ef1013077ecb7936c8254ee16e39fbc67435a9.tar.gz
Added persistence database viewer
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cc61a06..85dbbcb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,7 @@ AC_SUBST(CFLAGS)
AC_SUBST(CPPFLAGS)
AC_SUBST(LDFLAGS)
+
# Checks for header files.
AC_CHECK_HEADERS([fcntl.h limits.h stdlib.h string.h unistd.h])
@@ -59,6 +60,14 @@ AC_ARG_ENABLE([tests],
AM_CONDITIONAL([WANT_TESTS], [test x"$enable_tests" = "xyes"])
+
+AC_ARG_ENABLE([tools],
+ [AS_HELP_STRING([--enable-tools],[Enable tools])],
+ [enable_tools=$enableval],[enable_tools="no"])
+
+AM_CONDITIONAL([WANT_TOOLS], [test x"$enable_tools" = "xyes"])
+
+
# Checks for library functions.
AC_FUNC_CHOWN
@@ -199,7 +208,7 @@ AC_CONFIG_FILES([Makefile
config/pclCustomLibConfigFile.cfg
config/pclCustomLibConfigFileEmpty.cfg
src/Makefile
- persclient_tool/Makefile
+ tools/Makefile
test/Makefile])
AC_OUTPUT