summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIngo Huerner <ingo.huerner@xse.de>2014-01-24 14:33:15 +0100
committerIngo Huerner <ingo.huerner@xse.de>2014-01-24 14:33:15 +0100
commita756aac7ed08de6ab876fbfe88a46b07360a8922 (patch)
tree89a878740546cf464cfeaf8094fe364df7c3366d /configure.ac
parentbdca9b7b7fabd6f6a6506a33b39c1a6d1a667703 (diff)
downloadpersistence-client-library-a756aac7ed08de6ab876fbfe88a46b07360a8922.tar.gz
File backups on seperate partition; Fixed bug 146; created performance benchmark; minor optimization; disabled PAS interface by default, to enable use configure --enable-pasinterface
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 27f7587..03af087 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,6 +96,26 @@ AC_MSG_NOTICE([Tests enabled: $enable_tests])
AC_MSG_NOTICE([Local check enabled: $localcheck])
+# enable persistence administration service dbus interface ###########
+AC_ARG_ENABLE([pasinterface],
+ [AS_HELP_STRING([--enable-pasinterface],[Enable pas interface])],
+ [use_pasinterface=$enableval],
+ [use_pasinterface="no"])
+
+AM_CONDITIONAL([USE_PASINTERFACE], [test x"$use_pasinterface" = "no"])
+
+if test "$use_pasinterface" != "yes" -a "$use_pasinterface" != "no"; then
+ AC_MSG_ERROR([Invalid pas interface check mode specified: $use_pasinterface. Only "yes" or "no" is valid])
+else
+ AC_MSG_NOTICE([Use pas interface check is: $use_pasinterface])
+
+ if test "$use_pasinterface" = "yes"; then
+ AC_DEFINE_UNQUOTED([USE_PASINTERFACE], [1], [pasinterface enabled])
+ fi
+fi
+######################################################################
+
+
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug],
[enable debugging, default: no]),