summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorihuerner <ihuerner@b9707d8c-442e-47db-affb-152dabb2260b>2012-08-30 11:43:42 +0000
committerihuerner <ihuerner@b9707d8c-442e-47db-affb-152dabb2260b>2012-08-30 11:43:42 +0000
commita437ec80062eef34e861c18488838464aeac1f3b (patch)
treefba05100ed40a6d9beaa5854d08555e0da08a16d /configure.ac
parentf27098df091819c7eb467607b0ceeb1739a0add4 (diff)
downloadpersistence-client-library-a437ec80062eef34e861c18488838464aeac1f3b.tar.gz
Added debug version to configure; Now custom client lib functions will be called; stabilized custom library feature; added new test data; Now custom client lib functions will be called; Added debug configure switch (debug was by default activated (rev. 1380)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2fe5356..eec633d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,9 @@ AC_GNU_SOURCE()
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+# Overwrite the build in defaults
+CFLAGS="-Wall -O2"
+
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
@@ -73,6 +76,20 @@ fi
AC_MSG_NOTICE([Tests enabled: $enable_tests])
AC_MSG_NOTICE([Local check enabled: $localcheck])
+
+AC_ARG_ENABLE(debug,
+AS_HELP_STRING([--enable-debug],
+ [enable debugging, default: no]),
+[case "${enableval}" in
+ yes) debug=true ;;
+ no) debug=false ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-debug]) ;;
+esac],
+[debug=false])
+
+AM_CONDITIONAL(DEBUG, test x"$debug" = x"true")
+
+
#AC_CONFIG_FILES([Makefile
# persistence_client_library.pc
# src/Makefile