summaryrefslogtreecommitdiff
path: root/libstdc++-v3/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libstdc++-v3/src/Makefile.am')
-rw-r--r--libstdc++-v3/src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/libstdc++-v3/src/Makefile.am b/libstdc++-v3/src/Makefile.am
index d218ceaa9ca..4295d4dda66 100644
--- a/libstdc++-v3/src/Makefile.am
+++ b/libstdc++-v3/src/Makefile.am
@@ -189,6 +189,7 @@ sources = \
condition_variable.cc \
chrono.cc \
thread.cc \
+ future.cc \
${host_sources} \
${host_sources_extra}
@@ -297,6 +298,11 @@ thread.lo: thread.cc
thread.o: thread.cc
$(CXXCOMPILE) -std=gnu++0x -c $<
+future.lo: future.cc
+ $(LTCXXCOMPILE) -std=gnu++0x -c $<
+future.o: future.cc
+ $(CXXCOMPILE) -std=gnu++0x -c $<
+
if GLIBCXX_LDBL_COMPAT
# Use special rules for compatibility-ldbl.cc compilation, as we need to
# pass -mlong-double-64.