summaryrefslogtreecommitdiff
path: root/libstdc++-v3/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libstdc++-v3/configure.ac')
-rw-r--r--libstdc++-v3/configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac
index 7607e5b732e..49de141be7b 100644
--- a/libstdc++-v3/configure.ac
+++ b/libstdc++-v3/configure.ac
@@ -130,6 +130,8 @@ GLIBCXX_ENABLE_PARALLEL([yes])
GLIBCXX_ENABLE_CXX_FLAGS
GLIBCXX_ENABLE_FULLY_DYNAMIC_STRING([no])
GLIBCXX_ENABLE_EXTERN_TEMPLATE([yes])
+GLIBCXX_ENABLE_PYTHON
+GLIBCXX_ENABLE_WERROR([yes])
# Checks for operating systems support that doesn't require linking.
GLIBCXX_CHECK_MATH_PROTO
@@ -164,9 +166,6 @@ GLIBCXX_CHECK_GETTIMEOFDAY
# NB: The default is [no], because otherwise it requires linking.
GLIBCXX_ENABLE_LIBSTDCXX_TIME([no])
-# For gthread support
-GLIBCXX_CHECK_GTHREADS
-
AC_LC_MESSAGES
# For hardware_concurrency
@@ -335,6 +334,9 @@ GLIBCXX_CONDITIONAL(GLIBCXX_LDBL_COMPAT, test $ac_ldbl_compat = yes)
# This depends on GLIBCXX_ENABLE_SYMVERS and GLIBCXX_IS_NATIVE.
GLIBCXX_CONFIGURE_TESTSUITE
+# For gthread support. Depends on GLIBCXX_ENABLE_SYMVERS.
+GLIBCXX_CHECK_GTHREADS
+
# Define documentation rules conditionally.
# See if makeinfo has been installed and is modern enough