summaryrefslogtreecommitdiff
path: root/libjava/classpath/native/jni/gconf-peer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libjava/classpath/native/jni/gconf-peer/Makefile.am')
-rw-r--r--libjava/classpath/native/jni/gconf-peer/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/libjava/classpath/native/jni/gconf-peer/Makefile.am b/libjava/classpath/native/jni/gconf-peer/Makefile.am
new file mode 100644
index 00000000000..d8821832639
--- /dev/null
+++ b/libjava/classpath/native/jni/gconf-peer/Makefile.am
@@ -0,0 +1,12 @@
+nativeexeclib_LTLIBRARIES = libgconfpeer.la
+
+libgconfpeer_la_SOURCES = GConfNativePeer.c
+
+libgconfpeer_la_LIBADD = $(top_builddir)/native/jni/classpath/native_state.lo \
+ $(top_builddir)/native/jni/classpath/jcl.lo
+
+AM_LDFLAGS = @CLASSPATH_MODULE@ @GCONF_LIBS@ @GDK_LIBS@
+
+AM_CPPFLAGS = @CLASSPATH_INCLUDES@
+
+AM_CFLAGS = @WARNING_CFLAGS@ @ERROR_CFLAGS@ @GCONF_CFLAGS@ @GDK_CFLAGS@