summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4da04b76fdf..431cb170e16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1442,6 +1442,12 @@ case "$have_compiler:$host:$target:$enable_bootstrap" in
;;
esac
+# When bootstrapping with GCC, build stage 1 in C++98 mode to ensure that a
+# C++98 compiler can still start the bootstrap.
+if test "$enable_bootstrap:$GXX" = "yes:yes"; then
+ CXX="$CXX -std=c++98"
+fi
+
# Used for setting $lt_cv_objdir
_LT_CHECK_OBJDIR