summaryrefslogtreecommitdiff
path: root/libstdc++-v3/include/Makefile.am
diff options
context:
space:
mode:
authordoko <doko@138bc75d-0d04-0410-961f-82ee72b054a4>2013-05-18 23:39:38 +0000
committerdoko <doko@138bc75d-0d04-0410-961f-82ee72b054a4>2013-05-18 23:39:38 +0000
commitadda1ffc4833cf2ea48cbf8d5854d6e7a41c245f (patch)
treeedaea14d7de3a9d972a0552dfb74e19f970bf27c /libstdc++-v3/include/Makefile.am
parent475ac686fff3caa7bb7c20b6235aa3856a048fad (diff)
downloadgcc-adda1ffc4833cf2ea48cbf8d5854d6e7a41c245f.tar.gz
2013-05-19 Matthias Klose <doko@ubuntu.com>
* include/Makefile.am (bits_headers): Remove ${bits_host_headers}. (ext_headers): Remove ${ext_host_headers}. (stamp-${host_alias}): Create ${host_builddir}/../ext. (stamp-host): Link ${bits_host_headers} and ${ext_host_headers}. (install-headers): Install ${bits_host_headers} and ${ext_host_headers}. * include/Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@199072 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/include/Makefile.am')
-rw-r--r--libstdc++-v3/include/Makefile.am19
1 files changed, 12 insertions, 7 deletions
diff --git a/libstdc++-v3/include/Makefile.am b/libstdc++-v3/include/Makefile.am
index cbf4f1a549d..e8ef7066bcd 100644
--- a/libstdc++-v3/include/Makefile.am
+++ b/libstdc++-v3/include/Makefile.am
@@ -172,8 +172,7 @@ bits_headers = \
${bits_srcdir}/valarray_array.tcc \
${bits_srcdir}/valarray_before.h \
${bits_srcdir}/valarray_after.h \
- ${bits_srcdir}/vector.tcc \
- ${bits_host_headers}
+ ${bits_srcdir}/vector.tcc
bits_host_headers = \
${glibcxx_srcdir}/${CPU_OPT_BITS_RANDOM}
@@ -536,8 +535,7 @@ ext_headers = \
${ext_srcdir}/vstring.tcc \
${ext_srcdir}/vstring_fwd.h \
${ext_srcdir}/vstring_util.h \
- ${ext_compat_headers} \
- ${ext_host_headers}
+ ${ext_compat_headers}
ext_compat_headers = \
${backward_srcdir}/hash_set \
@@ -1050,13 +1048,14 @@ stamp-profile-impl: ${profile_impl_headers}
stamp-${host_alias}:
@-mkdir -p ${host_builddir}
+ @-mkdir -p ${host_builddir}/../ext
@$(STAMP) stamp-${host_alias}
# Host includes static.
# XXX Missing dependency info for {host_headers_extra}
-stamp-host: ${host_headers} ${host_headers_noinst} stamp-${host_alias}
+stamp-host: ${host_headers} ${bits_host_headers} ${ext_host_headers} ${host_headers_noinst} stamp-${host_alias}
@cd ${host_builddir} && {\
- $(LN_S) ${host_headers} . || true ;\
+ $(LN_S) ${host_headers} ${bits_host_headers} . || true ;\
$(LN_S) ${glibcxx_srcdir}/$(BASIC_FILE_H) basic_file.h || true ;\
$(LN_S) ${glibcxx_srcdir}/$(ALLOCATOR_H) c++allocator.h || true ;\
$(LN_S) ${glibcxx_srcdir}/$(CSTDIO_H) c++io.h || true ;\
@@ -1066,6 +1065,9 @@ stamp-host: ${host_headers} ${host_headers_noinst} stamp-${host_alias}
$(LN_S) ${glibcxx_srcdir}/$(CMESSAGES_H) messages_members.h || true ;\
$(LN_S) ${glibcxx_srcdir}/$(CTIME_H) time_members.h || true;\
} 2>/dev/null
+ @cd ${host_builddir}/../ext && {\
+ $(LN_S) ${ext_host_headers} . || true ;\
+ } 2>/dev/null
$(STAMP) stamp-host
# Host includes dynamic.
@@ -1292,9 +1294,12 @@ install-headers:
for file in ${profile_impl_headers}; do \
$(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${profile_impl_builddir}; done
$(mkinstalldirs) $(DESTDIR)${host_installdir}
- for file in ${host_headers} ${host_headers_extra} \
+ for file in ${host_headers} ${bits_host_headers} ${host_headers_extra} \
${thread_host_headers}; do \
$(INSTALL_DATA) $${file} $(DESTDIR)${host_installdir}; done
+ $(mkinstalldirs) $(DESTDIR)${host_installdir}/../ext
+ for file in ${ext_host_headers}; do \
+ $(INSTALL_DATA) $${file} $(DESTDIR)${host_installdir}/../ext; done
# By adding these files here, automake will remove them for 'make clean'
CLEANFILES = ${pch_output} ${pch_output_anchors} stamp-host