summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Kosnik <bkoz@gcc.gnu.org>2000-10-17 08:25:08 +0000
committerBenjamin Kosnik <bkoz@gcc.gnu.org>2000-10-17 08:25:08 +0000
commit9ece379a8a290603ecbafcd30dac259fc7c880a4 (patch)
treeca758d85d8aa5ae51afe442a86f12910b08488c6 /libstdc++-v3/Makefile.am
parent030d2f3414de32f736a23b39fa182548441a862f (diff)
downloadgcc-9ece379a8a290603ecbafcd30dac259fc7c880a4.tar.gz
Shadow headers would work if libsupc++ was strict about namespaces.
2000-10-16 Benjamin Kosnik <bkoz@gnu.org> Shadow headers would work if libsupc++ was strict about namespaces. This only possible if g++ maps std::size_t -> size_t. (Hint hint.) * include/c_std/assert.h: Add guards. * include/c_std/bits/std_climits.h: Correct typo. * include/c_std/ctype.h: Remove #error. * libio/libioP.h: Break up extern "C" bits around includes. * libio/libio.h: Only include C headers, or else _C_legacy namespaces will be nested. * libio/libioP.h: Same here. From-SVN: r36900
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index b32a151cd8b..0c5c09f2b54 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -121,4 +121,4 @@ AM_MAKEFLAGS = \
"NM_FOR_BUILD=$(NM_FOR_BUILD)" \
"NM_FOR_TARGET=$(NM_FOR_TARGET)" \
"DESTDIR=$(DESTDIR)" \
- "WERROR=$(WERROR)" \ No newline at end of file
+ "WERROR=$(WERROR)"