summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorMark Mitchell <mark@codesourcery.com>2004-08-02 20:28:22 +0000
committerMark Mitchell <mmitchel@gcc.gnu.org>2004-08-02 20:28:22 +0000
commit4c24b21a47dc8d146c8e4699e4b5a593a00fd9a9 (patch)
tree83cf70f3bb386c3241e58e367ac7decf0c8985a8 /libstdc++-v3/Makefile.am
parente0d9dfa2451d8dc8f5e4e09930bed6855af73c4f (diff)
downloadgcc-4c24b21a47dc8d146c8e4699e4b5a593a00fd9a9.tar.gz
Makefile.am (hosted_source): Add libmath and testsuite.
* Makefile.am (hosted_source): Add libmath and testsuite. (SUBDIRS): Remove them. * acinclude.m4: (GLIBCXX_ENABLED_HOSTED): Default to freestanding on arm*-*-symbianelf*. * crossconfig.m4: Add arm*-*-symbianelf* support. * include/c_std/std/std_cstdlib.h (stdlib.h): Do not include it when freestanding. Do not bring names into std:: namespace with "using" when freestanding. Declare required functions and macros when freestanding. * libsupc++/Makefile.am (c_sources): Do not include cp-demangle.c when freestanding. * libsupc++/del_op.cc: Declare "free" only when freestanding. * libsupc++/eh_alloc.cc (cstring): Include it only when hosted. (malloc): Declare when freestanding. (free): Likewise. (memset): Likewise. (__cxa_allocate_exception): Call malloc, not std::malloc. Likewise for memset. (__cxa_free_exception): Likewise for free. * libsupc++/new_op.cc: Declare "malloc" when freestanding. * libsupc++/pure.cc (writestr): Define to nothing when freestanding. * libsupc++/vterminate.cc: Do not define anything when freestanding. * Makefile.in: Regenerated. * aclocal.m4: Likewise. * configure: Likewise. * include/Makefile.in: Likewise. * libmath/Makefile.in: Likewise. * libsupc++/Makefile.in: Likewise. * po/Makefile.in: Likewise. * src/Makefile.in: Likewise. * testsuite/Makefile.in: Likewise. From-SVN: r85452
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index 8c03714269f..d17fcca5b40 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -25,11 +25,10 @@
include $(top_srcdir)/fragment.am
if GLIBCXX_HOSTED
- # Possibly libmath as well...
- hosted_source = src po
+ hosted_source = libmath src po testsuite
endif
## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
-SUBDIRS = include libmath libsupc++ $(hosted_source) testsuite
+SUBDIRS = include libsupc++ $(hosted_source)
# These rules are messy, but are hella worth it.
doxygen: