summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authorAlexandre Oliva <aoliva@redhat.com>2002-03-15 22:46:58 +0000
committerAlexandre Oliva <aoliva@gcc.gnu.org>2002-03-15 22:46:58 +0000
commit201d203b7996312dbb97b05c567ddbb234c5940b (patch)
tree5e9d4bafb559302c96ca20a0789fe7d1ae063491 /libjava/Makefile.am
parent89a1ba6d32c5fd0111aa6dd639dba2de523c40c9 (diff)
downloadgcc-201d203b7996312dbb97b05c567ddbb234c5940b.tar.gz
Makefile.am (jv_convert_LDADD): Don't list libraries that are already implicitly brought in from libgcj.la.
* Makefile.am (jv_convert_LDADD): Don't list libraries that are already implicitly brought in from libgcj.la. (gij_LDADD, rmic_LDADD, rmiregistry_LDADD): Likewise. * Makefile.in: Rebuilt. From-SVN: r50853
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index b3cbb0c700e..fd6d371fffd 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -429,7 +429,7 @@ jv_convert_LINK = $(GCJLINK)
## system libraries we need (via the specs file).
## We need the -L so that gcj can find libgcj with `-lgcj'.
## FIXME: should be _libs on some systems.
-jv_convert_LDADD = libgcj.la $(GCLIBS) $(THREADLIBS) $(ZLIBS) -L$(here)/.libs
+jv_convert_LDADD = libgcj.la -L$(here)/.libs
## Depend on the spec file to make sure it is up to date before
## linking this program.
jv_convert_DEPENDENCIES = $(convert_source_files:.java=.lo) \
@@ -446,7 +446,7 @@ gij_LINK = $(GCJLINK)
## system libraries we need (via the specs file).
## We need the -L so that gcj can find libgcj with `-lgcj'.
## FIXME: should be _libs on some systems.
-gij_LDADD = libgcj.la $(GCLIBS) $(THREADLIBS) $(ZLIBS) -L$(here)/.libs
+gij_LDADD = libgcj.la -L$(here)/.libs
## Depend on the spec file to make sure it is up to date before
## linking this program.
gij_DEPENDENCIES = $(GCDEPS) $(THREADDEPS) $(ZDEPS) libgcj.la libgcj.spec
@@ -462,7 +462,7 @@ rmic_LINK = $(GCJLINK)
## system libraries we need (via the specs file).
## We need the -L so that gcj can find libgcj with `-lgcj'.
## FIXME: should be _libs on some systems.
-rmic_LDADD = libgcj.la $(GCLIBS) $(THREADLIBS) $(ZLIBS) -L$(here)/.libs
+rmic_LDADD = libgcj.la -L$(here)/.libs
## Depend on the spec file to make sure it is up to date before
## linking this program.
rmic_DEPENDENCIES = $(GCDEPS) $(THREADDEPS) $(ZDEPS) libgcj.la libgcj.spec
@@ -478,7 +478,7 @@ rmiregistry_LINK = $(GCJLINK)
## system libraries we need (via the specs file).
## We need the -L so that gcj can find libgcj with `-lgcj'.
## FIXME: should be _libs on some systems.
-rmiregistry_LDADD = libgcj.la $(GCLIBS) $(THREADLIBS) $(ZLIBS) -L$(here)/.libs
+rmiregistry_LDADD = libgcj.la -L$(here)/.libs
## Depend on the spec file to make sure it is up to date before
## linking this program.
rmiregistry_DEPENDENCIES = $(GCDEPS) $(THREADDEPS) $(ZDEPS) libgcj.la libgcj.spec