summaryrefslogtreecommitdiff
path: root/libiberty/configure.in
diff options
context:
space:
mode:
authorghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2000-01-04 16:09:57 +0000
committerghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2000-01-04 16:09:57 +0000
commit6d93ad3843f49a2b47da4c741d2c9f4d511b504f (patch)
tree78647095cb02b3c2357d89ef789e8166846eb99a /libiberty/configure.in
parenta693b51b848446b64535b490acdcec115ce7431c (diff)
downloadgcc-6d93ad3843f49a2b47da4c741d2c9f4d511b504f.tar.gz
* configure.in (ac_libiberty_warn_cflags): Turn on warnings if
we're using gcc. * Makefile.in (COMPILE.c): Add @ac_libiberty_warn_cflags@ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@31205 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
index 10b8294198b..cc1b2c2082b 100644
--- a/libiberty/configure.in
+++ b/libiberty/configure.in
@@ -55,6 +55,7 @@ AC_PROG_CC_GNU
if test $ac_cv_prog_gcc = yes; then
GCC=yes
+ ac_libiberty_warn_cflags='-W -Wall -Wtraditional'
dnl Check whether -g works, even if CFLAGS is set, in case the package
dnl plays around with CFLAGS (such as to build both debugging and
dnl normal versions of a library), tasteless as that idea is.
@@ -71,9 +72,11 @@ dnl normal versions of a library), tasteless as that idea is.
fi
else
GCC=
+ ac_libiberty_warn_cflags=
test "${CFLAGS+set}" = set || CFLAGS="-g"
fi
])
+AC_SUBST(ac_libiberty_warn_cflags)
LIB_AC_PROG_CC