summaryrefslogtreecommitdiff
path: root/libgomp/Makefile.am
diff options
context:
space:
mode:
authorPaolo Bonzini <bonzini@gnu.org>2006-01-25 19:17:57 +0000
committerRichard Henderson <rth@gcc.gnu.org>2006-01-25 11:17:57 -0800
commit03b8fe495d716c004f5491eb2347537f115ab2d8 (patch)
tree3ed40bb4cdbf2ad9a5a53d51d9e40585078f01cf /libgomp/Makefile.am
parentb8795eddf5bebda36a22098be7b7810a7f6f2185 (diff)
downloadgcc-03b8fe495d716c004f5491eb2347537f115ab2d8.tar.gz
re PR libgomp/25884 (libgomp should not require perl to compile)
PR libgomp/25884 * Makefile.am (omp.h, omp_lib.h, omp_lib.f90, libgomp_f.h): Remove. * configure.ac (PERL): Don't set. (gstdint.h, omp.h, omp_lib.h, omp_lib.f90, libgomp_f.h): Create here. (OMP_LOCK_SIZE, OMP_LOCK_ALIGN, OMP_LOCK_KIND, OMP_NEST_LOCK_SIZE, OMP_NEST_LOCK_ALIGN, OMP_NEST_LOCK_KIND): New substitutions. * omp.h.in: Wrap the new configure substitutions with @ characters. * omp_lib.h.in, omp_lib.f90.in, libgomp_f.h.in: Likewise. * aclocal.m4, configure, Makefile.in: Regenerate. * mkomp_h.pl: Delete. From-SVN: r110220
Diffstat (limited to 'libgomp/Makefile.am')
-rw-r--r--libgomp/Makefile.am11
1 files changed, 0 insertions, 11 deletions
diff --git a/libgomp/Makefile.am b/libgomp/Makefile.am
index 21e4001b4c9..55f93730375 100644
--- a/libgomp/Makefile.am
+++ b/libgomp/Makefile.am
@@ -38,17 +38,6 @@ if USE_FORTRAN
nodist_include_HEADERS += omp_lib.mod omp_lib_kinds.mod
endif
-omp.h: omp.h.in mkomp_h.pl
- $(PERL) -w $(srcdir)/mkomp_h.pl "$(COMPILE)" $(srcdir)/omp.h.in omp.h
-omp_lib.h: omp_lib.h.in mkomp_h.pl
- $(PERL) -w $(srcdir)/mkomp_h.pl "$(COMPILE)" $(srcdir)/omp_lib.h.in \
- omp_lib.h
-omp_lib.f90: omp_lib.f90.in mkomp_h.pl
- $(PERL) -w $(srcdir)/mkomp_h.pl "$(COMPILE)" $(srcdir)/omp_lib.f90.in \
- omp_lib.f90
-libgomp_f.h: libgomp_f.h.in mkomp_h.pl
- $(PERL) -w $(srcdir)/mkomp_h.pl "$(COMPILE)" $(srcdir)/libgomp_f.h.in \
- libgomp_f.h
omp_lib_kinds.mod: omp_lib.mod
:
omp_lib.mod: omp_lib.f90