summaryrefslogtreecommitdiff
path: root/libgomp/Makefile.am
diff options
context:
space:
mode:
authorDavid Edelsohn <dje.gcc@gmail.com>2020-06-22 21:27:18 +0000
committerDavid Edelsohn <dje.gcc@gmail.com>2020-06-22 21:31:48 +0000
commit0164e59835de81d758fd4c56248ad7a46435fbfa (patch)
tree5f33fcb2b515b2ad7f2aeda7c50322d502936ee8 /libgomp/Makefile.am
parent67f6ef3b3804a0ddc6926e992f6020ed95e11ea6 (diff)
downloadgcc-0164e59835de81d758fd4c56248ad7a46435fbfa.tar.gz
build: Use -include instead of conditional include.
Automake and GNU Make both use the endif keyword, which conflicts and elicits an error for matching if/ifdef and endif. This patch changes the conditional include to use "-include" to prevent a warning about a possible empty tmake_file. libgomp/ChangeLog 2020-06-22 David Edelsohn <dje.gcc@gmail.com> * Makefile.am: Use -include. * Makefile.in: Regenerate. libatomic/ChangeLog 2020-06-22 David Edelsohn <dje.gcc@gmail.com> * Makefile.am: Use -include. * Makefile.in: Regenerate. libstdc++-v3/ChangeLog 2020-06-22 David Edelsohn <dje.gcc@gmail.com> * Makefile.am: Use -include. * Makefile.in: Regenerate. libgfortran/ChangeLog 2020-06-22 David Edelsohn <dje.gcc@gmail.com> * Makefile.am: Use -include. * Makefile.in: Regenerate.
Diffstat (limited to 'libgomp/Makefile.am')
-rw-r--r--libgomp/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/libgomp/Makefile.am b/libgomp/Makefile.am
index 16b69956949..586c930a4d7 100644
--- a/libgomp/Makefile.am
+++ b/libgomp/Makefile.am
@@ -142,8 +142,6 @@ CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO)
MAINTAINERCLEANFILES = $(srcdir)/libgomp.info
# target overrides
-ifneq ($(tmake_file),)
-include $(tmake_file)
-endif
+-include $(tmake_file)
include $(top_srcdir)/../multilib.am