summaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorJanne Blomqvist <jb@gcc.gnu.org>2014-05-12 22:20:50 +0300
committerJanne Blomqvist <jb@gcc.gnu.org>2014-05-12 22:20:50 +0300
commitf7b6856fa4cb73c3b4b4f41a1fbced4c5cf7ebd1 (patch)
tree5e1a25c4efb5695ee9b6e4032fabd70f7ee8d83a /libgfortran/configure.ac
parentdff8943f5465569db3d9f46ceea5ff193c7a5654 (diff)
downloadgcc-f7b6856fa4cb73c3b4b4f41a1fbced4c5cf7ebd1.tar.gz
Use -std=gnu11 instead of -std=gnu99 for libgfortran C code.
2014-05-12 Janne Blomqvist <jb@gcc.gnu.org> * configure.ac (AM_CFLAGS): Use -std=gnu11. (CFLAGS): Likewise. * configure: Regenerated. From-SVN: r210334
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index 24dbf2b4fa5..212628540a2 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -139,12 +139,13 @@ AM_PROG_CC_C_O
# Add -Wall -fno-repack-arrays -fno-underscoring if we are using GCC.
if test "x$GCC" = "xyes"; then
AM_FCFLAGS="-I . -Wall -Werror -fimplicit-none -fno-repack-arrays -fno-underscoring"
- ## We like to use C99 routines when available. This makes sure that
+ ## We like to use C11 and C99 routines when available. This makes
+ ## sure that
## __STDC_VERSION__ is set such that libc includes make them available.
- AM_CFLAGS="-std=gnu99 -Wall -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -Wextra -Wwrite-strings"
+ AM_CFLAGS="-std=gnu11 -Wall -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -Wextra -Wwrite-strings"
## Compile the following tests with the same system header contents
## that we'll encounter when compiling our own source files.
- CFLAGS="-std=gnu99 $CFLAGS"
+ CFLAGS="-std=gnu11 $CFLAGS"
fi
AC_SUBST(AM_FCFLAGS)
AC_SUBST(AM_CFLAGS)