summaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorJanne Blomqvist <jb@gcc.gnu.org>2011-04-15 07:21:19 +0300
committerJanne Blomqvist <jb@gcc.gnu.org>2011-04-15 07:21:19 +0300
commit2aadeae27f225b6b0624a534de16106fb1d2a546 (patch)
treef5a7917eb1d48a5794fc9f24a57e3d55139f7573 /libgfortran/configure.ac
parentf54d331e46f11ac7b5876a22b30ba52e69985a48 (diff)
downloadgcc-2aadeae27f225b6b0624a534de16106fb1d2a546.tar.gz
PR 47571 Fix bootstrap regression on alpha-dec-osf
From-SVN: r172469
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index 8235c883572..cf38fb024ea 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -492,14 +492,15 @@ LIBGFOR_CHECK_FLOAT128
# Check for GNU libc feenableexcept
AC_CHECK_LIB([m],[feenableexcept],[have_feenableexcept=yes AC_DEFINE([HAVE_FEENABLEEXCEPT],[1],[libm includes feenableexcept])])
-# At least for glibc, clock_gettime is in librt. But don't pull that
-# in if it still doesn't give us the function we want.
-# This test is copied from libgomp, and modified to not link in -lrt
-# as libgfortran calls clock_gettime via a weak reference.
+# At least for glibc and Tru64, clock_gettime is in librt. But don't
+# pull that in if it still doesn't give us the function we want. This
+# test is copied from libgomp, and modified to not link in -lrt as
+# libgfortran calls clock_gettime via a weak reference if it's found
+# in librt.
if test $ac_cv_func_clock_gettime = no; then
AC_CHECK_LIB(rt, clock_gettime,
- [AC_DEFINE(HAVE_CLOCK_GETTIME, 1,
- [Define to 1 if you have the `clock_gettime' function.])])
+ [AC_DEFINE(HAVE_CLOCK_GETTIME_LIBRT, 1,
+ [Define to 1 if you have the `clock_gettime' function in librt.])])
fi
# Check for SysV fpsetmask