summaryrefslogtreecommitdiff
path: root/libgfortran/Makefile.am
diff options
context:
space:
mode:
authorSandra Loosemore <sandra@codesourcery.com>2021-09-06 21:25:11 -0700
committerSandra Loosemore <sandra@codesourcery.com>2021-09-06 21:28:50 -0700
commit13beaf9e8d2d8264c0ad8f6504793fdcf26f3f73 (patch)
tree8ea243d3de3ba6344f71871647a24076a4363e3b /libgfortran/Makefile.am
parent546ecb0054af302acf0839c7f3eb78598f8c0672 (diff)
downloadgcc-13beaf9e8d2d8264c0ad8f6504793fdcf26f3f73.tar.gz
Fortran: Revert to non-multilib-specific ISO_Fortran_binding.h
Commit fef67987cf502fe322e92ddce22eea7ac46b4d75 changed the libgfortran build process to generate multilib-specific versions of ISO_Fortran_binding.h from a template, by running gfortran to identify the values of the Fortran kind constants C_LONG_DOUBLE, C_FLOAT128, and C_INT128_T. This caused multiple problems with search paths, both for build-tree testing and installed-tree use, not all of which have been fixed. This patch reverts to a non-multilib-specific .h file that uses GCC's predefined preprocessor symbols to detect the supported types and map them to kind values in the same way as the Fortran front end. 2021-09-06 Sandra Loosemore <sandra@codesourcery.com> libgfortran/ * ISO_Fortran_binding-1-tmpl.h: Deleted. * ISO_Fortran_binding-2-tmpl.h: Deleted. * ISO_Fortran_binding-3-tmpl.h: Deleted. * ISO_Fortran_binding.h: New file to replace the above. * Makefile.am (gfor_cdir): Remove MULTISUBDIR. (ISO_Fortran_binding.h): Simplify to just copy the file. * Makefile.in: Regenerated. * mk-kinds-h.sh: Revert pieces no longer needed for ISO_Fortran_binding.h.
Diffstat (limited to 'libgfortran/Makefile.am')
-rw-r--r--libgfortran/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/libgfortran/Makefile.am b/libgfortran/Makefile.am
index 6fc4b465c6e..366198b5938 100644
--- a/libgfortran/Makefile.am
+++ b/libgfortran/Makefile.am
@@ -31,7 +31,7 @@ version_dep =
endif
gfor_c_HEADERS = ISO_Fortran_binding.h
-gfor_cdir = $(libdir)/gcc/$(target_alias)/$(gcc_version)$(MULTISUBDIR)/include
+gfor_cdir = $(libdir)/gcc/$(target_alias)/$(gcc_version)/include
LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS)) \
$(lt_host_flags)
@@ -1079,15 +1079,9 @@ fpu-target.inc: fpu-target.h $(srcdir)/libgfortran.h
# Place ISO_Fortran_binding.h also under include/ in the build directory such
# that it can be used for in-built-tree testsuite runs without interference of
# other files in the build dir - like intrinsic .mod files or other .h files.
-ISO_Fortran_binding.h: $(srcdir)/ISO_Fortran_binding-1-tmpl.h \
- $(srcdir)/ISO_Fortran_binding-2-tmpl.h \
- $(srcdir)/ISO_Fortran_binding-3-tmpl.h \
- kinds.inc
+ISO_Fortran_binding.h: $(srcdir)/ISO_Fortran_binding.h
-rm -f $@
- cp $(srcdir)/ISO_Fortran_binding-1-tmpl.h $@
- $(COMPILE) -E -dD $(srcdir)/ISO_Fortran_binding-2-tmpl.h \
- | grep '^#define CFI_type' >> $@
- cat $(srcdir)/ISO_Fortran_binding-3-tmpl.h >> $@
+ cp $(srcdir)/ISO_Fortran_binding.h $@
$(MKDIR_P) include
-rm -f include/ISO_Fortran_binding.h
cp $@ include/ISO_Fortran_binding.h