summaryrefslogtreecommitdiff
path: root/libgcc/configure.ac
diff options
context:
space:
mode:
authorJack Howarth <howarth@bromo.med.uc.edu>2010-03-30 13:08:52 +0000
committerRichard Biener <rguenth@gcc.gnu.org>2010-03-30 13:08:52 +0000
commit368fabd5a33634289fa1bcd5cf10921dd1ebb667 (patch)
tree289b5c46ab914bf871f7cb4ed1773b3ade816a05 /libgcc/configure.ac
parent2bcba94ba40f6ed885bbf03d54fb8eab24213e1a (diff)
downloadgcc-368fabd5a33634289fa1bcd5cf10921dd1ebb667.tar.gz
re PR c/43553 (libgcc built with -DHAVE_CC_TLS against xgcc when emutls in use)
2010-03-30 Jack Howarth <howarth@bromo.med.uc.edu> PR c/43553 * Makefile.in (INTERNAL_CFLAGS): Add @set_use_emutls@. * configure.ac: Use GCC_CHECK_EMUTLS to see if emulated TLS is used and substitute set_use_emutls. * configure: Regenerated. From-SVN: r157821
Diffstat (limited to 'libgcc/configure.ac')
-rw-r--r--libgcc/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/libgcc/configure.ac b/libgcc/configure.ac
index e735019dfc7..ce467dda598 100644
--- a/libgcc/configure.ac
+++ b/libgcc/configure.ac
@@ -238,6 +238,14 @@ if test "$enable_tls $gcc_cv_have_cc_tls" = "yes yes"; then
fi
AC_SUBST(set_have_cc_tls)
+# See if we have emulated thread-local storage.
+GCC_CHECK_EMUTLS
+set_use_emutls=
+if test "$enable_tls $gcc_cv_use_emutls" = "yes yes"; then
+ set_use_emutls="-DUSE_EMUTLS"
+fi
+AC_SUBST(set_use_emutls)
+
# Conditionalize the makefile for this target machine.
tmake_file_=
for f in ${tmake_file}