summaryrefslogtreecommitdiff
path: root/libdecnumber/configure.ac
diff options
context:
space:
mode:
authorMarek Polacek <polacek@redhat.com>2022-11-22 21:10:31 -0500
committerMarek Polacek <polacek@redhat.com>2022-11-22 21:10:31 -0500
commit04711f5189a72c2fcaeed520d65582704adca042 (patch)
treef0eb61aee9cb51bf6ff14bfef4429b1f77e99d26 /libdecnumber/configure.ac
parent30f399ee9318bcb44e3e2debde086303157a347d (diff)
downloadgcc-04711f5189a72c2fcaeed520d65582704adca042.tar.gz
Revert "configure: Implement --enable-host-pie"
This reverts commit 251c72a68af3a8b0638705b73ef120ffdf0053eb.
Diffstat (limited to 'libdecnumber/configure.ac')
-rw-r--r--libdecnumber/configure.ac19
1 files changed, 2 insertions, 17 deletions
diff --git a/libdecnumber/configure.ac b/libdecnumber/configure.ac
index 14f67f926d1..0794031ec83 100644
--- a/libdecnumber/configure.ac
+++ b/libdecnumber/configure.ac
@@ -100,23 +100,8 @@ AC_C_BIGENDIAN
# Enable --enable-host-shared.
AC_ARG_ENABLE(host-shared,
[AS_HELP_STRING([--enable-host-shared],
- [build host code as shared libraries])])
-AC_SUBST(enable_host_shared)
-
-# Enable --enable-host-pie.
-AC_ARG_ENABLE(host-pie,
-[AS_HELP_STRING([--enable-host-pie],
- [build host code as PIE])])
-AC_SUBST(enable_host_pie)
-
-if test x$enable_host_shared = xyes; then
- PICFLAG=-fPIC
-elif test x$enable_host_pie = xyes; then
- PICFLAG=-fPIE
-else
- PICFLAG=
-fi
-
+ [build host code as shared libraries])],
+[PICFLAG=-fPIC], [PICFLAG=])
AC_SUBST(PICFLAG)
# Enable Intel CET on Intel CET enabled host if jit is enabled.