summaryrefslogtreecommitdiff
path: root/gotools/configure.ac
diff options
context:
space:
mode:
authorRainer Orth <ro@CeBiTec.Uni-Bielefeld.DE>2015-01-20 09:26:50 +0000
committerRainer Orth <ro@gcc.gnu.org>2015-01-20 09:26:50 +0000
commit5bd8d5c12cf5bdef08a24dd6223bdf30cc0a03d3 (patch)
tree7cb07f2082bc60ac9f1a160134c2c066b0fc993e /gotools/configure.ac
parent42df23a65ee2b93425c2627f3d312dcfe7fcf122 (diff)
downloadgcc-5bd8d5c12cf5bdef08a24dd6223bdf30cc0a03d3.tar.gz
Link with -lrt on Solaris 10
* configure.ac: Check if sched_yield and/or nanosleep need -lrt. * configure: Regenerate. * Makefile.am (go$(EXEEXT), gofmt$(EXEEXT), cgo$(EXEEXT)): Link with $(LIBS). * Makefile.in: Regenerate. From-SVN: r219882
Diffstat (limited to 'gotools/configure.ac')
-rw-r--r--gotools/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/gotools/configure.ac b/gotools/configure.ac
index 24f4498d279..e4528a4f31e 100644
--- a/gotools/configure.ac
+++ b/gotools/configure.ac
@@ -79,6 +79,10 @@ AC_CACHE_CHECK([for socket libraries], gotools_cv_lib_sockets,
NET_LIBS="$gotools_cv_lib_sockets"
AC_SUBST(NET_LIBS)
+dnl Test if -lrt is required for sched_yield and/or nanosleep.
+AC_SEARCH_LIBS([sched_yield], [rt])
+AC_SEARCH_LIBS([nanosleep], [rt])
+
AC_CONFIG_FILES(Makefile)
AC_OUTPUT