summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorRainer Orth <ro@CeBiTec.Uni-Bielefeld.DE>2017-10-26 12:22:21 +0000
committerRainer Orth <ro@gcc.gnu.org>2017-10-26 12:22:21 +0000
commit8c2e5ecf991b9427afab0679b26a7a99dae2e078 (patch)
tree2300a4f981b5b74fd38080d60b842abec9ffbcab /gcc/configure.ac
parentf073de07ad00d4be604bdbaeab14786850932601 (diff)
downloadgcc-8c2e5ecf991b9427afab0679b26a7a99dae2e078.tar.gz
Use -xbrace_comment=no with recent Solaris/x86 as
* configure.ac (gcc_cv_as_ix86_xbrace_comment): Check if assembler supports -xbrace_comment option. * configure: Regenerate. * config.in: Regenerate. * config/i386/sol2.h (ASM_XBRACE_COMMENT_SPEC): Define. (ASM_CPU_SPEC): Use it. From-SVN: r254103
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index d905d0d980a..7c0a903c4cd 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -4103,6 +4103,11 @@ foo: nop
;;
esac
+ gcc_GAS_CHECK_FEATURE([-xbrace_comment], gcc_cv_as_ix86_xbrace_comment,,
+ [-xbrace_comment=no], [.text],,
+ [AC_DEFINE(HAVE_AS_XBRACE_COMMENT_OPTION, 1,
+ [Define if your assembler supports -xbrace_comment option.])])
+
# Test if the assembler supports the section flag 'e' for specifying
# an excluded section.
gcc_GAS_CHECK_FEATURE([.section with e], gcc_cv_as_section_has_e,