summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorTrevor Saunders <tbsaunde@gcc.gnu.org>2016-11-14 10:58:48 +0000
committerTrevor Saunders <tbsaunde@gcc.gnu.org>2016-11-14 10:58:48 +0000
commit61214be10b12d26d2ec7855d9a8681a155b0f953 (patch)
treec22752892fde2e66aeecd39618b75adcc48d4e5c /gcc/configure.ac
parent5129b43be675171c2e4742ae4b1e073249314818 (diff)
downloadgcc-61214be10b12d26d2ec7855d9a8681a155b0f953.tar.gz
remove conditional compilation of HAVE_AS_LEB128 code
gcc/ChangeLog: 2016-08-20 Trevor Saunders <tbsaunde+gcc@tbsaunde.org> * acinclude.m4 (gcc_GAS_CHECK_FEATURE): Support doing an action if the feature isn't available. * configure: Regenerate. * configure.ac: define HAVE_AS_LEB128 to 0 when not available. * dwarf2asm.c (dw2_asm_output_data_uleb128): Always compile code for HAVE_AS_LEB128. (dw2_asm_output_data_sleb128): Likewise. (dw2_asm_output_delta_uleb128): Likewise. (dw2_asm_output_delta_sleb128): Likewise. * except.c (output_one_function_exception_table): Likewise. (dw2_size_of_call_site_table): Likewise. (sjlj_size_of_call_site_table): Likewise. * dwarf2out.c (output_loc_list): Likewise. (output_rnglists): Likewise. From-SVN: r242381
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 2f9b859eafb..140b9f9ac90 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -2753,6 +2753,8 @@ L2:],
fi
fi]],
[AC_DEFINE(HAVE_AS_LEB128, 1,
+ [Define if your assembler supports .sleb128 and .uleb128.])],
+ [AC_DEFINE(HAVE_AS_LEB128, 0,
[Define if your assembler supports .sleb128 and .uleb128.])])
# Check if we have assembler support for unwind directives.