summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authordje <dje@138bc75d-0d04-0410-961f-82ee72b054a4>2016-01-21 18:50:17 +0000
committerdje <dje@138bc75d-0d04-0410-961f-82ee72b054a4>2016-01-21 18:50:17 +0000
commit2f6cdf65c79e3ed5e976b44efd07a09e94cfad0c (patch)
tree6e4ba2e9e671383181b9b3362dd3dcbcb3c374d0 /gcc/configure.ac
parent81f464dc2c9f1370ff6cc750795185ee58575290 (diff)
downloadgcc-2f6cdf65c79e3ed5e976b44efd07a09e94cfad0c.tar.gz
* configure.ac (gcc_cv_as_powerpc_mfcrf, gcc_cv_as_machine_directive):
Detangle. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@232697 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 4727b2ad6a9..4dc7c109a26 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -4172,10 +4172,8 @@ value:'
;;
powerpc*-*-*)
+
case $target in
- *-*-aix*) conftest_s=' .machine "pwr5"
- .csect .text[[PR]]
- mfcr 3,128';;
*-*-darwin*)
gcc_GAS_CHECK_FEATURE([.machine directive support],
gcc_cv_as_machine_directive,,,
@@ -4185,7 +4183,14 @@ value:'
echo you can get it from: ftp://gcc.gnu.org/pub/gcc/infrastructure/cctools-528.5.dmg >&2
test x$build = x$target && exit 1
fi
- conftest_s=' .text
+ ;;
+ esac
+
+ case $target in
+ *-*-aix*) conftest_s=' .machine "pwr5"
+ .csect .text[[PR]]
+ mfcr 3,128';;
+ *-*-darwin*) conftest_s=' .text
mfcr r3,128';;
*) conftest_s=' .machine power4
.text