summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2004-11-04 17:03:59 +0000
committerhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2004-11-04 17:03:59 +0000
commite8eddfdd142cb31243bfbaa058d5e5a13eee3c75 (patch)
treeb5b12256441e776499a309d75fa3418468b724d0 /configure.in
parent44f0e47cbc15dea914b3c6569e86ccdec1f9b196 (diff)
downloadgcc-e8eddfdd142cb31243bfbaa058d5e5a13eee3c75.tar.gz
Update configure.in/configure.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@90068 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 19 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 8712586b3a5..f64e2e8b827 100644
--- a/configure.in
+++ b/configure.in
@@ -1653,10 +1653,25 @@ case "${host}" in
;;
esac
+# If no --enable-shared nor --disable-shared is specified, we set up
+# LD_LIBRARY_PATH when we build for gcc.
+case $enable_shared in
+"")
+ if test -d ${srcdir}/gcc; then
+ set_lib_path=yes
+ else
+ set_lib_path=no
+ fi
+ ;;
+*)
+ set_lib_path=$enable_shared
+ ;;
+esac
+
# If --enable-shared was set, we must set LD_LIBRARY_PATH so that the
# binutils tools will find libbfd.so.
-case "${enable_shared}" in
- no | "") SET_LIB_PATH= ;;
+case "${set_lib_path}" in
+ no) SET_LIB_PATH= ;;
*) SET_LIB_PATH="\$(REALLY_SET_LIB_PATH)" ;;
esac
@@ -2334,8 +2349,8 @@ AC_SUBST(stage2_werror_flag)
# used.
SET_GCC_LIB_PATH=
if test -d ${srcdir}/gcc && test x${is_cross_compiler} = xno; then
- case "${enable_shared}" in
- no | "") ;;
+ case "${set_lib_path}" in
+ no) ;;
*)
eval "d=\$$RPATH_ENVVAR"
if test x"$d" != x; then