summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRobert Millan <robertmh@gnu.org>2004-08-03 20:48:48 +0000
committerNathanael Nerode <neroden@gcc.gnu.org>2004-08-03 20:48:48 +0000
commit98a5bb3b0e2d9d0337c6ebc449613bc31c75a14e (patch)
tree9fff97d6fd6e82bdd2d6b2f2d34682c6d3d2eb3a /configure.in
parent4d4473645282ded9c162611b8a658ad34671c824 (diff)
downloadgcc-98a5bb3b0e2d9d0337c6ebc449613bc31c75a14e.tar.gz
configure.in: Turn mt-linux into mt-gnu.
ChangeLog: 2004-08-01 Robert Millan <robertmh@gnu.org> * configure.in: Turn mt-linux into mt-gnu. Use mt-gnu and enable libmudflap for all GNU-based systems (with Glibc). * configure: Regenerate. config/ChangeLog: 2004-08-01 Robert Millan <robertmh@gnu.org> * mt-linux: Rename to ... * mt-gnu: ... this. libffi/ChangeLog: 2004-08-01 Robert Millan <robertmh@gnu.org> * configure.ac: Detect knetbsd-gnu and kfreebsd-gnu. * configure: Regenerate. From-SVN: r85501
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 3c17693513b..f758a729b76 100644
--- a/configure.in
+++ b/configure.in
@@ -143,7 +143,7 @@ host_libs="intl mmalloc libiberty opcodes bfd readline tcl tk itcl tix libgui zl
# know that we are building the simulator.
# binutils, gas and ld appear in that order because it makes sense to run
# "make check" in that particular order.
-host_tools="texinfo byacc flex bison binutils gas ld gcc sid sim gdb make patch prms send-pr gprof etc expect dejagnu ash bash bzip2 m4 autoconf automake libtool diff rcs fileutils shellutils time textutils wdiff find uudecode hello tar gzip indent recode release sed utils guile perl gawk findutils gettext zip fastjar"
+host_tools="texinfo byacc flex bison binutils gas ld gcc sid sim gdb make patch prms send-pr gprof etc expect dejagnu ash bash bzip2 m4 autoconf automake libtool diff rcs fileutils shellutils time textutils wdiff find uudecode hello tar gzip indent recode release sed utils guile perl gawk findutils gettext zip fastjar gnattools"
# libgcj represents the runtime libraries only used by gcj.
libgcj="target-libffi \
@@ -330,6 +330,7 @@ ENABLE_LIBADA=$enableval,
ENABLE_LIBADA=yes)
if test "${ENABLE_LIBADA}" != "yes" ; then
noconfigdirs="$noconfigdirs target-libada"
+ noconfigdirs="$noconfigdirs gnattools"
fi
# Save it here so that, even in case of --enable-libgcj, if the Java
@@ -358,8 +359,8 @@ no)
;;
"")
case "${target}" in
- *-*-linux*)
- # Enable libmudflap by default in GNU/Linux.
+ *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu)
+ # Enable libmudflap by default in GNU and friends.
;;
*-*-freebsd*)
# Enable libmudflap by default in FreeBSD.
@@ -1420,8 +1421,8 @@ case "${target}" in
powerpc-*-netware*)
target_makefile_frag="config/mt-netware"
;;
- *-*-linux*)
- target_makefile_frag="config/mt-linux"
+ *-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu)
+ target_makefile_frag="config/mt-gnu"
;;
*-*-aix4.[[3456789]]* | *-*-aix[[56789]].*)
# nm and ar from AIX 4.3 and above require -X32_64 flag to all ar and nm