summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2011-03-21 12:26:30 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2011-03-21 12:26:30 +0000
commit55184b41ccf424f7c275f79463ebcb9fd93f5004 (patch)
tree5dbbe6e9b187f5d7b351d9c462be4348aaa35075 /configure.ac
parentbbb514dcf4bb7d49582abf414ccaffa26d166eae (diff)
downloadgcc-55184b41ccf424f7c275f79463ebcb9fd93f5004.tar.gz
PR bootstrap/48120:
* configure.ac (pwllib): Use LIBS instead of LDFLAGS. Add -lstdc++ -lm to LIBS. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@171225 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6b17b68dc0a..58bbe448e53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1677,10 +1677,10 @@ fi
if test "x$with_ppl" != xno; then
if test "x$pwllib" = x; then
- saved_LDFLAGS="$LDFLAGS"
- LDFLAGS="$LDFLAGS $ppllibs"
- AC_CHECK_LIB(pwl,PWL_handle_timeout,[pwllib="-lpwl"])
- LDFLAGS="$saved_LDFLAGS"
+ saved_LIBS="$LIBS"
+ LIBS="$LIBS $ppllibs -lstdc++ -lm"
+ AC_CHECK_LIB(pwl, PWL_handle_timeout, [pwllib="-lpwl"])
+ LIBS="$saved_LIBS"
fi
ppllibs="$ppllibs -lppl_c -lppl $pwllib -lgmpxx"