summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbstarynk <bstarynk@138bc75d-0d04-0410-961f-82ee72b054a4>2009-11-17 13:30:25 +0000
committerbstarynk <bstarynk@138bc75d-0d04-0410-961f-82ee72b054a4>2009-11-17 13:30:25 +0000
commit4e9fcf901016372bb4e7fb4f840a6db2fb8e4626 (patch)
treefb28abdf9aa398faa2d1803425b758f8b3f7d461 /configure.ac
parent85c9b60c6a60a3afffa837a023c616b3e0a5e6a5 (diff)
downloadgcc-4e9fcf901016372bb4e7fb4f840a6db2fb8e4626.tar.gz
2009-11-17 Basile Starynkevitch <basile@starynkevitch.net>
MELT branch merged with trunk rev 154243 git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/melt-branch@154246 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 20 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 43b1970e056..f663e5daf44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,7 +161,7 @@ build_tools="build-texinfo build-byacc build-flex build-bison build-m4 build-fix
# these libraries are used by various programs built for the host environment
#
-host_libs="intl mmalloc libiberty opcodes bfd readline tcl tk itcl libgui zlib libcpp libdecnumber gmp mpfr mpc ppl gdbm cloog libiconv"
+host_libs="intl mmalloc libiberty opcodes bfd readline tcl tk itcl libgui zlib libcpp libdecnumber gmp mpfr mpc ppl gdbm cloog libelf libiconv"
# these tools are built for the host environment
# Note, the powerpc-eabi build depends on sim occurring before gdb in order to
@@ -1516,7 +1516,7 @@ pplinc=
AC_ARG_WITH(ppl, [ --with-ppl=PATH Specify prefix directory for the installed PPL package
Equivalent to --with-ppl-include=PATH/include
- plus --with-ppl-lib=PATH/lib],, with_ppl=yes)
+ plus --with-ppl-lib=PATH/lib])
AC_ARG_WITH(ppl_include, [ --with-ppl-include=PATH Specify directory for installed PPL include files])
AC_ARG_WITH(ppl_lib, [ --with-ppl-lib=PATH Specify the directory for the installed PPL library])
@@ -1524,7 +1524,7 @@ case $with_ppl in
no)
ppllibs=
;;
- yes)
+ "" | yes)
;;
*)
ppllibs="-L$with_ppl/lib -lppl_c -lppl -lgmpxx"
@@ -1538,8 +1538,9 @@ if test "x$with_ppl_lib" != x; then
ppllibs="-L$with_ppl_lib -lppl_c -lppl -lgmpxx"
fi
if test "x$with_ppl$with_ppl_include$with_ppl_lib" = x && test -d ${srcdir}/ppl; then
- ppllibs='-L$$r/$(HOST_SUBDIR)/ppl/.libs -L$$r/$(HOST_SUBDIR)/ppl/_libs -lppl_c -lppl -lgmpxx '
- pplinc='-I$$r/$(HOST_SUBDIR)/ppl/include -I$$s/ppl/include '
+ ppllibs='-L$$r/$(HOST_SUBDIR)/ppl/interfaces/C/.libs -L$$r/$(HOST_SUBDIR)/ppl/interfaces/C/_libs -L$$r/$(HOST_SUBDIR)/ppl/src/.libs -L$$r/$(HOST_SUBDIR)/ppl/src/_libs -lppl_c -lppl -lgmpxx '
+ pplinc='-I$$r/$(HOST_SUBDIR)/ppl/src -I$$r/$(HOST_SUBDIR)/ppl/interfaces/C '
+ enable_ppl_version_check=no
fi
AC_ARG_ENABLE(ppl-version-check,
@@ -1571,7 +1572,7 @@ clooginc=" -DCLOOG_PPL_BACKEND "
AC_ARG_WITH(cloog, [ --with-cloog=PATH Specify prefix directory for the installed CLooG-PPL package
Equivalent to --with-cloog-include=PATH/include
- plus --with-cloog-lib=PATH/lib],, with_cloog=yes)
+ plus --with-cloog-lib=PATH/lib])
AC_ARG_WITH(cloog_include, [ --with-cloog-include=PATH Specify directory for installed CLooG include files])
AC_ARG_WITH(cloog_lib, [ --with-cloog-lib=PATH Specify the directory for the installed CLooG library])
@@ -1584,7 +1585,7 @@ case $with_cloog in
clooglibs=
clooginc=
;;
- yes)
+ "" | yes)
;;
*)
clooglibs="-L$with_cloog/lib -lcloog"
@@ -1600,6 +1601,7 @@ fi
if test "x$with_cloog$with_cloog_include$with_cloog_lib" = x && test -d ${srcdir}/cloog; then
clooglibs='-L$$r/$(HOST_SUBDIR)/cloog/.libs -L$$r/$(HOST_SUBDIR)/cloog/_libs -lcloog '
clooginc='-I$$r/$(HOST_SUBDIR)/cloog/include -I$$s/cloog/include -DCLOOG_PPL_BACKEND '
+ enable_cloog_version_check=no
fi
AC_ARG_ENABLE(cloog-version-check,
@@ -1691,10 +1693,11 @@ if test x"$enable_lto" = x"yes" ; then
if test "x$with_libelf$with_libelf_include$with_libelf_lib" = x \
&& test -d ${srcdir}/libelf; then
- libelflibs='-L$$r/$(HOST_SUBDIR)/libelf/.libs -L$$r/$(HOST_SUBDIR)/libelf/_libs -lelf '
- libelfinc='-I$$r/$(HOST_SUBDIR)/libelf/include -I$$s/libelf/include'
+ libelflibs='-L$$r/$(HOST_SUBDIR)/libelf/lib -lelf '
+ libelfinc='-D__LIBELF_INTERNAL__ -I$$r/$(HOST_SUBDIR)/libelf/lib -I$$s/libelf/lib'
LIBS="$libelflibs $LIBS"
- fi
+
+ else
CFLAGS="$CFLAGS $libelfinc"
CPPFLAGS="$CPPFLAGS $libelfinc"
@@ -1764,6 +1767,8 @@ to specify its location.])
CPPFLAGS="$saved_CPPFLAGS"
LIBS="$saved_LIBS"
+ fi
+
# Flags needed for libelf.
AC_SUBST(libelflibs)
AC_SUBST(libelfinc)
@@ -1876,7 +1881,8 @@ if test -d ${srcdir}/gcc; then
exit 1
fi
- if test "$language" = "c++" -a "$ENABLE_BUILD_WITH_CXX" = "yes"; then
+ if test "$language" = "c++" \
+ && test "$ENABLE_BUILD_WITH_CXX" = "yes"; then
boot_language=yes
fi
@@ -3394,6 +3400,9 @@ case "$target" in
hppa*64*-*-hpux*) ;;
hppa*-*-hpux*) compare_exclusions="gcc/cc*-checksum\$(objext) | */libgcc/lib2funcs* | gcc/ada/*tools/*" ;;
esac
+case " $configdirs " in
+*" ppl "*) compare_exclusions="$compare_exclusions | ppl/src/ppl-config.o" ;;
+esac
AC_SUBST(compare_exclusions)
AC_CONFIG_FILES([Makefile],