summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 9eebba73..dfc9bbed 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -2132,6 +2132,14 @@ watchpoint1:
@AWKPATH="$(srcdir)" $(AWK) -D -f $@.awk $(srcdir)/$@.in < $(srcdir)/$@.script >_$@ 2>&1 || echo EXIT CODE: $$? >>_$@
@-$(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@
+pty1:
+ @echo $@
+ @case `uname` in \
+ openedition*) : ;; \
+ *) AWKPATH="$(srcdir)" $(AWK) -f $@.awk >_$@ 2>&1 || echo EXIT CODE: $$? >>_$@ ; \
+ $(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@ ;; \
+ esac
+
# Targets generated for other tests:
include Maketests