summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorPeri <peri@srdi.org>2023-05-11 02:38:46 +0100
committerGitHub <noreply@github.com>2023-05-11 02:38:46 +0100
commitbb1890afd7d1eb33e95f36d1d9936dbd574260b6 (patch)
tree9c5d13d913e6dcd0fab15b8970c8805620305e81 /test/meson.build
parentfcd293f675fc7bfa0522186c5d68ef932eec6945 (diff)
downloadfuse-bb1890afd7d1eb33e95f36d1d9936dbd574260b6.tar.gz
Fix issue #746. (#782)
Added a secondary check in fuse_lib_unlink() after hide_node() to check again under a lock if the (now hidden) file is still open. If not then delete it. This should synchronise fuse_lib_unlink() with fuse_lib_release(), when nullpath_ok is set.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 1f5cb53..3d74b9a 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -13,6 +13,9 @@ td += executable('test_syscalls', 'test_syscalls.c',
td += executable('readdir_inode', 'readdir_inode.c',
include_directories: include_dirs,
install: false)
+td += executable('release_unlink_race', 'release_unlink_race.c',
+ dependencies: [ libfuse_dep ],
+ install: false)
test_scripts = [ 'conftest.py', 'pytest.ini', 'test_examples.py',
'util.py', 'test_ctests.py', 'test_custom_io.py' ]