summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDov Grobgeld <dov.grobgeld@gmail.com>2018-01-13 23:56:30 +0200
committerDov Grobgeld <dov.grobgeld@gmail.com>2018-01-13 23:56:30 +0200
commitad1da2a0d79f4d362d03d2b21834be9c505c5b74 (patch)
tree6af256432f6e29dcbe321ef003dd7791eeadeee4 /configure.ac
parent4a732cf9d28228a0698e9c6fa76206874b6125dd (diff)
downloadfribidi-ad1da2a0d79f4d362d03d2b21834be9c505c5b74.tar.gz
Less hackish cross compilation support.
* Changed hardcoded gcc for build compiler to use m4_ax_prog_cc_for_build.m4 instead as suggested by Khaled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 2 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 46634e1..363346d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -111,6 +111,7 @@ AC_SUBST(SIZEOF_INT)
AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(void *)
AC_CHECK_SIZEOF(wchar_t)
+AX_PROG_CC_FOR_BUILD
# Checks for compiler characteristics.
changequote(,)dnl
@@ -180,26 +181,7 @@ fi
fi
AM_CONDITIONAL(FRIBIDI_USE_GLIB, test x$FRIBIDI_USE_GLIB = x1)
-# A hack for supporting cross compilation
-if test $host != $build; then
- BUILD_CC="gcc"
- BUILD_CFLAGS="-O2 -g"
- BUILD_LDFLAGS=""
- BUILD_EXEEXT=""
-else
- BUILD_CC="${CC}"
- BUILD_CFLAGS="${CFLAGS}"
- BUILD_LDFLAGS="${LDFLAGS}"
- BUILD_EXEEXT="${EXEEXT}"
-fi
-
-# Continuation of hack to set up the proper include directories
-BUILD_CFLAGS="${BUILD_CFLAGS} -DHAVE_CONFIG_H -I.. -I../lib"
-
-AC_ARG_VAR([BUILD_CC])
-AC_ARG_VAR([BUILD_CFLAGS])
-AC_ARG_VAR([BUILD_LDFLAGS])
-AC_ARG_VAR([BUILD_EXEEXT])
+CFLAGS_FOR_BUILD="${CFLAGS_FOR_BUILD} -DHAVE_CONFIG_H -I.. -I../lib"
# Generate output
AC_CONFIG_FILES([fribidi.pc