summaryrefslogtreecommitdiff
path: root/packages/uuid
diff options
context:
space:
mode:
authornickysn <nickysn@3ad0048d-3df7-0310-abae-a5850022a9f2>2021-03-13 21:52:13 +0000
committernickysn <nickysn@3ad0048d-3df7-0310-abae-a5850022a9f2>2021-03-13 21:52:13 +0000
commit947f1fbab48fb5e268866fef99a7e53111d777ab (patch)
treef70710e93f6a849066a571d96dd1f72406be2788 /packages/uuid
parent1df4e051413aac8bcb360108ec82045b9fe3171e (diff)
downloadfpc-947f1fbab48fb5e268866fef99a7e53111d777ab.tar.gz
* regenerated makefiles after sync with trunk
git-svn-id: https://svn.freepascal.org/svn/fpc/branches/wasm@48951 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/uuid')
-rw-r--r--packages/uuid/Makefile2
-rw-r--r--packages/uuid/examples/Makefile10
2 files changed, 10 insertions, 2 deletions
diff --git a/packages/uuid/Makefile b/packages/uuid/Makefile
index 2793702e87..7e840cd3b2 100644
--- a/packages/uuid/Makefile
+++ b/packages/uuid/Makefile
@@ -2295,7 +2295,7 @@ ifdef CREATESHARED
override FPCOPT+=-Cg
endif
ifneq ($(findstring $(OS_TARGET),dragonfly freebsd openbsd netbsd linux solaris),)
-ifneq ($(findstring $(CPU_TARGET),x86_64 mips mipsel),)
+ifneq ($(findstring $(CPU_TARGET),x86_64 mips mipsel riscv64),)
override FPCOPT+=-Cg
endif
endif
diff --git a/packages/uuid/examples/Makefile b/packages/uuid/examples/Makefile
index 1c6409ba1e..231b373db4 100644
--- a/packages/uuid/examples/Makefile
+++ b/packages/uuid/examples/Makefile
@@ -912,10 +912,18 @@ else
ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),mips mipsel),)
FPCMAKE_CROSSGCCOPT=-mabi=32
else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),riscv64),)
+FPCMAKE_CROSSGCCOPT=-mabi=lp64
+else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),riscv32),)
+FPCMAKE_CROSSGCCOPT=-mabi=ilp32
+else
FPCMAKE_CROSSGCCOPT=-m32
endif
endif
endif
+endif
+endif
FPCMAKEGCCLIBDIR:=$(shell dirname `gcc $(FPCMAKE_CROSSGCCOPT) -print-libgcc-file-name`)
endif
endif
@@ -2735,7 +2743,7 @@ ifdef CREATESHARED
override FPCOPT+=-Cg
endif
ifneq ($(findstring $(OS_TARGET),dragonfly freebsd openbsd netbsd linux solaris),)
-ifneq ($(findstring $(CPU_TARGET),x86_64 mips mipsel),)
+ifneq ($(findstring $(CPU_TARGET),x86_64 mips mipsel riscv64),)
override FPCOPT+=-Cg
endif
endif