summaryrefslogtreecommitdiff
path: root/packages/tplylib
diff options
context:
space:
mode:
authornickysn <nickysn@3ad0048d-3df7-0310-abae-a5850022a9f2>2021-03-13 21:47:24 +0000
committernickysn <nickysn@3ad0048d-3df7-0310-abae-a5850022a9f2>2021-03-13 21:47:24 +0000
commitaed7424e21332198b9d11fa3ce1071a796a9e187 (patch)
treeefd91efb76959c74f5f9a55b36118a17cb8a0213 /packages/tplylib
parent62c237e276fb82d4b6f2ea98b9c0014279cda9b7 (diff)
parentf4b984d2356cc47030adc7378858c428a399a589 (diff)
downloadfpc-aed7424e21332198b9d11fa3ce1071a796a9e187.tar.gz
* synchronized with trunk
git-svn-id: https://svn.freepascal.org/svn/fpc/branches/wasm@48949 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/tplylib')
-rw-r--r--packages/tplylib/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/packages/tplylib/Makefile b/packages/tplylib/Makefile
index e891f2ff5a..41775fee7f 100644
--- a/packages/tplylib/Makefile
+++ b/packages/tplylib/Makefile
@@ -607,10 +607,18 @@ else
ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),mips mipsel),)
FPCMAKE_CROSSGCCOPT=-mabi=32
else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),riscv64),)
+FPCMAKE_CROSSGCCOPT=-mabi=lp64
+else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),riscv32),)
+FPCMAKE_CROSSGCCOPT=-mabi=ilp32
+else
FPCMAKE_CROSSGCCOPT=-m32
endif
endif
endif
+endif
+endif
FPCMAKEGCCLIBDIR:=$(shell dirname `gcc $(FPCMAKE_CROSSGCCOPT) -print-libgcc-file-name`)
endif
endif