summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2006-12-02 14:18:11 -0800
committerKeith Packard <keithp@neko.keithp.com>2006-12-02 14:18:11 -0800
commit2cae0512cdf3544ff78b04f6c05a4cb585e50bb8 (patch)
tree9c3e02619775098d8711b27ae7b39ba48571a431 /doc/Makefile.am
parent0f963b0d3ec417a39f6aa2ba22ba56c2a79d05aa (diff)
downloadfontconfig-2cae0512cdf3544ff78b04f6c05a4cb585e50bb8.tar.gz
A VPATH build of fontconfig-2.4.1 fails for various reasons. Bug 8933.
VPATH builds without doctools breaks as it cannot find the distributed pre-formatted documentation.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 3477eb7..5641dd9 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -142,7 +142,7 @@ fontconfig-devel.txt: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml
fontconfig-devel.pdf: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
$(RM) $@
- ../missing --run $(DOC2PDF) $< && mv local-$@ $@ \
+ $(top_srcdir)/missing --run $(DOC2PDF) $< && mv local-$@ $@ \
|| echo Failed to generate $@ >&2; \
(test -f $@ || echo $(DOC2PDF) is required to generate this file >> $@)
@@ -160,7 +160,7 @@ fontconfig-user.txt: local-fontconfig-user.sgml version.sgml confdir.sgml
fontconfig-user.pdf: local-fontconfig-user.sgml version.sgml confdir.sgml
$(RM) $@
- ../missing --run $(DOC2PDF) $< && mv local-$@ $@ \
+ $(top_srcdir)/missing --run $(DOC2PDF) $< && mv local-$@ $@ \
|| echo Failed to generate $@ >&2; \
(test -f $@ || echo $(DOC2PDF) is required to generate this file >> $@)
@@ -170,7 +170,14 @@ confdir.sgml: ${DOC_SRC}/confdir.sgml.in
CLEANFILES=confdir.sgml local-fontconfig-user.sgml local-fontconfig-devel.sgml
+htmldoc_DATA = $(HTML_DIR)/*
+
+$(HTML_DIR)/*: $(HTML_DIR)
+
else
+
+htmldoc_DATA = $(srcdir)/$(HTML_DIR)/*
+
all-local:
clean-local:
endif
@@ -179,6 +186,3 @@ htmldocdir=$(docdir)/$(HTML_DIR)
doc_DATA = $(DOC_FILES)
-htmldoc_DATA = $(HTML_DIR)/*
-
-$(HTML_DIR)/*: $(HTML_DIR)