summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 12 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index f4924b9..63e5e65 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,9 @@ flex_SOURCES = \
filter.c \
regex.c
+
+LDADD = lib/libcompat.a
+
libfl_a_SOURCES = \
libmain.c \
libyywrap.c
@@ -113,9 +116,9 @@ BUILT_SOURCES = \
skel.c
SUBDIRS = \
+ lib \
. \
doc \
- m4 \
examples \
po \
tools \
@@ -155,11 +158,11 @@ tblcmp.o: tblcmp.c flexdef.h flexint.h
yylex.o: yylex.c flexdef.h flexint.h parse.h
filter.o: filter.c flexdef.h flexint.h
-# Create the ChangeLog, but only if we're inside a cvs working directory
+# Create the ChangeLog, but only if we're inside a git working directory
-ChangeLog: $(srcdir)/tools/cvsauthors $(srcdir)/tools/cvs2cl.pl
- if [ -d CVS ] ; then \
- sh $(srcdir)/tools/cvs2cl.pl -F trunk -U $(srcdir)/tools/cvsauthors \
+ChangeLog: $(srcdir)/tools/git2cl
+ if [ -d $(srcdir)/.git ] ; then \
+ $(srcdir)/tools/git2cl > $@ \
; fi
# Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
@@ -206,4 +209,8 @@ indent:
done \
fi
+install-exec-hook:
+ cd $(DESTDIR)/$(bindir) && \
+ $(LN_S) -f flex$(EXEEXT) flex++$(EXEEXT)
+
.PHONY: ChangeLog tags indent