summaryrefslogtreecommitdiff
path: root/tests/test-bison-yylloc/Makefile.am
diff options
context:
space:
mode:
authorSam Thursfield <sam.thursfield@codethink.co.uk>2013-01-16 11:41:16 +0000
committerSam Thursfield <sam.thursfield@codethink.co.uk>2013-01-16 11:41:16 +0000
commitb3cac737802959c96ff35fb1b8a6a54e4a5f4812 (patch)
tree1be8e67d9d3d0064c8dd0b5132d06c3a1b168b40 /tests/test-bison-yylloc/Makefile.am
parent6b3c38ce0f98e7fa0476621ac64e8602655fdadf (diff)
downloadflex-b3cac737802959c96ff35fb1b8a6a54e4a5f4812.tar.gz
Commit files from flex 2.5.37 tarball
Flex has a circular dependency on itself when build from git.
Diffstat (limited to 'tests/test-bison-yylloc/Makefile.am')
-rw-r--r--tests/test-bison-yylloc/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/test-bison-yylloc/Makefile.am b/tests/test-bison-yylloc/Makefile.am
index 3be8907..1da3257 100644
--- a/tests/test-bison-yylloc/Makefile.am
+++ b/tests/test-bison-yylloc/Makefile.am
@@ -36,9 +36,14 @@ testname = test-bison-yylloc
scanner.c: $(srcdir)/scanner.l
$(FLEX) $<
+scanner.h: scanner.c
+scanner.o: parser.h
parser.c: $(srcdir)/parser.y
$(BISON) $(YFLAGS) $<
+parser.h: parser.c
+
+main.o: scanner.h parser.h
$(testname)$(EXEEXT): $(OBJS)
$(CC) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
@@ -48,6 +53,3 @@ test: $(testname)$(EXEEXT)
.c.o:
$(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
-
-parser.h: parser.c
-scanner.c main.o: parser.h