summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJosh Coalson <jcoalson@users.sourceforce.net>2002-08-23 06:45:23 +0000
committerJosh Coalson <jcoalson@users.sourceforce.net>2002-08-23 06:45:23 +0000
commit1f99eac2bbfc9a6ea84173840062886f4ffa8493 (patch)
tree9aa454a03d8560ad7135d821de815ce56146b87c /test/Makefile.am
parent3e94dad4f0902f3d146db0291b31887c61c13143 (diff)
downloadflac-1f99eac2bbfc9a6ea84173840062886f4ffa8493.tar.gz
fixes based on a pass over everything with autoconf/automake
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 7d6d4afd..a29960a0 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -15,16 +15,22 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+if FLaC__HAS_OGG
+OGG_TESTS = \
+ ./test_libOggFLAC.sh \
+ ./test_libOggFLAC++.sh
+endif
+
TESTS = \
./test_libFLAC.sh \
./test_libFLAC++.sh \
- ./test_libOggFLAC.sh \
- ./test_libOggFLAC++.sh \
+ $(OGG_TESTS) \
./test_metaflac.sh \
./test_streams.sh \
./test_bins.sh
EXTRA_DIST = \
+ Makefile.lite \
test_libFLAC.sh \
test_libFLAC++.sh \
test_libOggFLAC.sh \