summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorJosh Coalson <jcoalson@users.sourceforce.net>2002-07-16 16:09:53 +0000
committerJosh Coalson <jcoalson@users.sourceforce.net>2002-07-16 16:09:53 +0000
commit5e5fc016e124d58c5965f1ccbc2a2867f5a5bd38 (patch)
treed2150e0a40852089c461fad20affa856d8c60a56 /doc/Makefile.am
parentceacff2b18eda2d95768839e75c194a1657fbd45 (diff)
downloadflac-5e5fc016e124d58c5965f1ccbc2a2867f5a5bd38.tar.gz
reorganized doc directory
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 00000000..315e9e09
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,33 @@
+# flac - Command-line FLAC encoder/decoder
+# Copyright (C) 2002 Josh Coalson
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = . html
+
+FLAC.tag: Doxyfile
+ doxygen Doxyfile
+ rm -rf html/api
+ mv doxytmp/html html/api
+ rm -rf doxytmp
+
+docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
+
+doc_DATA = \
+ FLAC.tag
+
+EXTRA_DIST = Doxyfile $(doc_DATA)