summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartijn van Beurden <mvanb1@gmail.com>2021-12-31 21:02:59 +0100
committerMartijn van Beurden <mvanb1@gmail.com>2022-04-15 09:36:15 +0200
commitecede0bc72bd051d3c3e05440beb35c0c34b4b34 (patch)
tree14dd60bda1e54bdd3d54c9330c25dda1964495fa /configure.ac
parent13149acddd09653ece65dd882c66879ae5084832 (diff)
downloadflac-ecede0bc72bd051d3c3e05440beb35c0c34b4b34.tar.gz
Remove AC_C_VARARRAYS from configure.ac
With autoconf 2.70, the behaviour of AC_C_VARARRAYS has changed, causing a lot of warnings and as a result a cluttered make output. Doing some research as to where this comes from, I found an strange piece of code that seems to rely on a misunderstanding as to VLA's in C++. As I found, the C++ standard does not have VLA's. The configure.ac code and some code in libFLAC++ seems to think it does. This now causes strange behaviour. This commit removes the code relying on this behaviour and removing all VLA related autoconf macro's from configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 353637eb..8ca4d7b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,18 +54,8 @@ AC_CHECK_SIZEOF(off_t,1) # Fake default value.
AC_CHECK_SIZEOF([void*])
AC_SEARCH_LIBS([lround],[m], [AC_DEFINE(HAVE_LROUND,1,lround support)])
-AC_LANG_PUSH([C++])
-# c++ flavor first
-AC_C_VARARRAYS
-if test $ac_cv_c_vararrays = yes; then
- AC_DEFINE([HAVE_CXX_VARARRAYS], 1, [Define to 1 if C++ supports variable-length arrays.])
-fi
-AC_LANG_POP([C++])
-
-# c flavor
AM_PROG_CC_C_O
AC_C_INLINE
-AC_C_VARARRAYS
AC_C_TYPEOF
AC_CHECK_HEADERS([stdint.h inttypes.h byteswap.h sys/param.h sys/ioctl.h termios.h x86intrin.h cpuid.h])