summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2016-06-19 21:51:31 +1000
committerErik de Castro Lopo <erikd@mega-nerd.com>2016-06-20 20:42:44 +1000
commite120037f3c67b23fd9eef7ccd04d2df57fa1a9a6 (patch)
treeae4124966b36718d91e5d263f238b9c869dc1176 /configure.ac
parente58b36c8ea4d45b6e3d4fb5e5df747e5f8b6c9d2 (diff)
downloadflac-e120037f3c67b23fd9eef7ccd04d2df57fa1a9a6.tar.gz
Fix use of FLAC__SSE_OS configure variable
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4e0dd535..a4c689ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,11 +219,11 @@ AC_HELP_STRING([--disable-sse], [Disable SSE if the OS does not support SSE inst
no) sse_os=no ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-sse) ;;
esac],[sse_os=yes])
-AM_CONDITIONAL(FLaC__SSE_OS, test "x$sse_os" = xyes)
if test "x$sse_os" = xyes ; then
-AC_DEFINE(FLAC__SSE_OS)
-AH_TEMPLATE(FLAC__SSE_OS, [define if your operating system supports SSE instructions])
-fi
+ AC_DEFINE_UNQUOTED([FLAC__SSE_OS],[1],[Define if your operating system supports SSE instructions])
+else
+ AC_DEFINE_UNQUOTED([FLAC__SSE_OS],[0])
+ fi
AC_ARG_ENABLE(altivec,
AC_HELP_STRING([--disable-altivec], [Disable Altivec optimizations]),