summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2016-03-20 20:14:01 +1100
committerErik de Castro Lopo <erikd@mega-nerd.com>2016-03-20 20:44:59 +1100
commit9548d4b953c5373563d63aa0091aa64fbe2922dc (patch)
treec4dec184ed5acd838759433a3e97b69ee2a0625d /configure.ac
parent1be4f9537e306931a3c2115f9cfedc325fdef4e7 (diff)
downloadflac-9548d4b953c5373563d63aa0091aa64fbe2922dc.tar.gz
configure.ac: Force FLAC__HAS_OGG to 0 or 1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 04495e7e..4e0dd535 100644
--- a/configure.ac
+++ b/configure.ac
@@ -350,14 +350,16 @@ if test "x$want_ogg" != "xno"; then
XIPH_PATH_OGG(have_ogg=yes, AC_MSG_WARN([*** Ogg development enviroment not installed - Ogg support will not be built]))
fi
+FLAC__HAS_OGG=0
AM_CONDITIONAL(FLaC__HAS_OGG, [test "x$have_ogg" = xyes])
if test "x$have_ogg" = xyes ; then
- AC_DEFINE_UNQUOTED([FLAC__HAS_OGG],1,[define if you have the ogg library])
+ FLAC__HAS_OGG=1
OGG_PACKAGE="ogg"
else
- AC_DEFINE_UNQUOTED([FLAC__HAS_OGG],0)
have_ogg=no
fi
+AC_DEFINE_UNQUOTED([FLAC__HAS_OGG],$FLAC__HAS_OGG,[define if you have the ogg library])
+AC_SUBST(FLAC__HAS_OGG)
AC_SUBST(OGG_PACKAGE)
dnl check for i18n(internationalization); these are from libiconv/gettext