summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2022-02-21 18:21:11 +0100
committerMartijn van Beurden <mvanb1@gmail.com>2022-04-30 09:46:47 +0200
commit6cd28e855c71248ec40790922795590106be7076 (patch)
treeb65dd7db3da96055b9dd82f800e9c826ec2abb23 /configure.ac
parent63ac1c37bebbda5ca61ad5a05a1d8fba2883f629 (diff)
downloadflac-6cd28e855c71248ec40790922795590106be7076.tar.gz
Fix uclibc build
Commit 4fbb6d4f2ecf2a96c17ea9880108409f852c08a9 reverted commit 44036c9a9b45d03373fe90e9c112852bfc054c51 and so broke again the build on uclibc So put back the sys/auxv.h check as well as a getauxval check in a way that doesn't break iOS Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8a27028d..9ea6c9fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,7 +58,7 @@ AM_PROG_CC_C_O
AC_C_INLINE
AC_C_TYPEOF
-AC_CHECK_HEADERS([stdint.h inttypes.h byteswap.h sys/param.h sys/ioctl.h termios.h x86intrin.h cpuid.h arm_neon.h])
+AC_CHECK_HEADERS([stdint.h inttypes.h byteswap.h sys/auxv.h sys/param.h sys/ioctl.h termios.h x86intrin.h cpuid.h arm_neon.h])
XIPH_C_BSWAP32
XIPH_C_BSWAP16
@@ -90,6 +90,9 @@ fi
# For the XMMS plugin.
AC_CHECK_TYPES(socklen_t, [], [])
+dnl check for getauxval in standard library
+AC_CHECK_FUNCS(getauxval)
+
dnl check for getopt in standard library
dnl AC_CHECK_FUNCS(getopt_long , , [LIBOBJS="$LIBOBJS getopt.o getopt1.o"] )
AC_CHECK_FUNCS(getopt_long, [], [])