summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartijn van Beurden <mvanb1@gmail.com>2022-09-16 13:59:21 +0200
committerGitHub <noreply@github.com>2022-09-16 13:59:21 +0200
commit1cb364d8cfdf1abadac03c900ddd30de0291426d (patch)
treeac6a65d61270f875ec50a0d7a4a3d1f107c4a8ff /configure.ac
parent1a84604b2b2fa721adbe0a73e4190bbd87edfce7 (diff)
downloadflac-1cb364d8cfdf1abadac03c900ddd30de0291426d.tar.gz
Make sure git doesn't try to get version from other repository
Fixes https://github.com/xiph/flac/issues/443
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c771dfdc..5fa8d9db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -593,9 +593,9 @@ dnl for correct FLAC_API
AC_CHECK_PROG(GIT_FOUND,git,yes)
if test x$GIT_FOUND$enable_version_from_git = "xyesyes"; then
- GIT_COMMIT_TAG=`git -C $srcdir describe --tags --exact-match 2>/dev/null`
- GIT_COMMIT_HASH=`git -C $srcdir log -1 --pretty=format:%h 2>/dev/null`
- GIT_COMMIT_DATE=`git -C $srcdir log -1 --pretty=format:%cd --date=format:%Y%m%d 2>/dev/null`
+ GIT_COMMIT_TAG=`git -C $srcdir --git-dir=.git describe --tags --exact-match 2>/dev/null`
+ GIT_COMMIT_HASH=`git -C $srcdir --git-dir=.git log -1 --pretty=format:%h 2>/dev/null`
+ GIT_COMMIT_DATE=`git -C $srcdir --git-dir=.git log -1 --pretty=format:%cd --date=format:%Y%m%d 2>/dev/null`
if test ${#GIT_COMMIT_HASH} = 8 && test ${#GIT_COMMIT_DATE} = 8; then
GIT_COMMIT_VERSION_AVAIL=yes
if test ${#GIT_COMMIT_TAG} != 0 ; then